Support forums

Please check @brandnewbox_uk for support status updates.

Search     Advanced Search

   
PHP 7 Warnings  
Posted: 10 July 2017 02:46 AM —   [ Ignore ]  
Newbie
Rank
Total Posts:  5
Joined  2013-05-21

Data Grab is working well on my EE 2.11.19 site with Datagram 1.9.2. Is there a version of DG for EE2 that clears out some of the PHP warnings, such as:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Ajw_datagrab_upd has a deprecated constructor in /var/www/vhosts/mydomain.com/httpdocs/system/expressionengine/third_party/ajw_datagrab/upd.ajw_datagrab.php on line 12

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Ajw_datagrab_mcp has a deprecated constructor in /var/www/vhosts/mydomain.com/httpdocs/system/expressionengine/third_party/ajw_datagrab/mcp.ajw_datagrab.php on line 15

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Datagrab_model has a deprecated constructor in /var/www/vhosts/mydomain.com/httpdocs/system/expressionengine/third_party/ajw_datagrab/models/datagrab_model.php on line 11

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Datagrab_type has a deprecated constructor in /var/www/vhosts/mydomain.com/httpdocs/system/expressionengine/third_party/ajw_datagrab/libraries/Datagrab_type.php on line 12
A PHP Error was encountered
Severity: Warning
Message: Declaration of Ajw_json::fetch() should be compatible with Datagrab_type::fetch($settings)
Filename: ajw_json/dt.ajw_json.php
Line Number: 0
A PHP Error was encountered
Severity: Warning
Message: Declaration of Ajw_json::initialise_sub_item($item, $id, $config, $field) should be compatible with Datagrab_type::initialise_sub_item($item, $id)
Filename: ajw_json/dt.ajw_json.php
Line Number: 0
A PHP Error was encountered
Severity: Warning
Message: Declaration of Ajw_json::get_sub_item($item, $id, $config, $field) should be compatible with Datagrab_type::get_sub_item($item, $id)
Filename: ajw_json/dt.ajw_json.php
Line Number: 0

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Ajw_MagpieRSS has a deprecated constructor in /var/www/vhosts/mydomain.com/httpdocs/system/expressionengine/third_party/ajw_datagrab/datatypes/ajw_feed/dt.ajw_feed.php on line 261

Profile
 
 
Posted: 11 July 2017 09:18 AM —   [ Ignore ]   [ # 1 ]  
Administrator
Avatar
RankRankRankRank
Total Posts:  1320
Joined  2006-04-12

These warnings should be fixed in the latest version of DataGrab. You should be able to download this from the account you used to buy DataGrab on devot-ee.com or brandnewbox.co.uk. Email me on support@brandnewbox.co.uk if you don’t have the account details anymore.

Andrew

Profile
 
 
Posted: 11 July 2017 09:00 PM —   [ Ignore ]   [ # 2 ]  
Newbie
Rank
Total Posts:  5
Joined  2013-05-21

Kudos! That was it! I thought I was on the latest EE2 but there was a minor version after. Fixed!

Profile
 
 
   
 

‹‹ Unserialize issue      ExpressionEngine 3 Datagrab 2.02 Batch Import Issue ››

Select A Theme