Support forums

Please check @brandnewbox_uk for support status updates.

Search     Advanced Search
Can’t get JSON import working on EE 3  
Posted: 01 September 2017 03:41 AM —  
Newbie
Rank
Total Posts:  2
Joined  2017-09-01

Greetings,

I just purchased my 4th license for Datagrab, I’ve used it to great success on previous projects when importing a CSV. This is my first time using it for ExpressionEngine 3 and first time trying to work with the JSON import.

Unfortunately, I can’t get the JSON import function to work, which is critical for my current project. The goal is to import data from an API directly to the ExpressionEngine database.

I’m testing a very simple API here

https://reqres.in/api/users/2

I’m using ExpressionEngine 3.5.10 and Datagrab 2.0.2

I’ve tested it from a local url and from the API url

Datagrab shows that there are 4 fields per entry

[screenshot url below]
https://pasteboard.co/GIia46a.jpg

And I can assign one of the fields to the title

[screenshot url below]
https://pasteboard.co/GIidqPD.jpg

But when I run the import, I get errors

[screenshot url below]
https://pasteboard.co/GIie2q6.jpg

Found new entry:

Could not create new entry:

missing_title title

unable_to_create_url_title url_title

Found new entry:

Could not create new entry:

missing_title title

unable_to_create_url_title url_title

Found new entry:

Could not create new entry:

missing_title title

unable_to_create_url_title url_title

Found new entry:

Could not create new entry:

missing_title title

unable_to_create_url_title url_title


——————————————————————-

 

Profile
 
Posted: 06 September 2017 08:25 AM —   [ # 1 ]  
Administrator
Avatar
RankRankRankRank
Total Posts:  1339
Joined  2006-04-12

Hi,

Sorry for not getting back to you sooner - I have been out of the office for a while.

Would it be possible to send me a copy of the data file? I have made some updates to the JSON importer but would like to test it first.

Thanks,
Andrew
support@brandnewbox.co.uk

Profile
 
Posted: 07 September 2017 05:05 PM —   [ # 2 ]  
Newbie
Rank
Total Posts:  2
Joined  2017-09-01

Hi Andrew,

Thanks for the response, I’m trying to import the JSON data available at this test API.

https://reqres.in/api/users/2

I’ve pasted it below
——————————

{"data":{"id":2,"first_name":"Janet","last_name":"Weaver","avatar":"https://s3.amazonaws.com/uifaces/faces/twitter/josephstein/128.jpg"}}

Profile
 

‹‹ Requesting hooks to be added to Datagrab - patch included      Creating XML imports: use field names as XML tags? ››

Select A Theme