Support forums

Please check @brandnewbox_uk for support status updates.

Search     Advanced Search
Initialization Error when attempting to “Check Settings”.  
Posted: 17 June 2019 08:11 PM —  
Newbie
Rank
Total Posts:  2
Joined  2019-05-29

Hi, I’ve been wrestling with this error for the better part of the day and have finally broken down in defeat. Does anyone have any idea as to why I’m getting these errors? I have confirmed that the data I’m attempting to check in is valid json. But what seams to be happening is that there are no settings being passed to the initializer.

PHP Fatal error:  Uncaught Error: Call to a member function initialise() on null in C:\inetpub\wwwroot\system\user\addons\ajw_datagrab\mcp.ajw_datagrab.php:208
Stack trace:
#0 [internal function]: Ajw_datagrab_mcp->check_settings()
#1 C:\inetpub\wwwroot\system\ee\EllisLab\ExpressionEngine\Controller\Addons\Addons.php(1662): call_user_func_array(Array, Array)
#2 C:\inetpub\wwwroot\system\ee\EllisLab\ExpressionEngine\Controller\Addons\Addons.php(946): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings(‘ajw_datagrab’, ‘check_settings’, Array)
#3 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings(‘ajw_datagrab’, ‘check_settings’)
#4 C:\inetpub\wwwroot\system\ee\EllisLab\ExpressionEngine\Core\Core.php(241): call_user_func_array(Array, Array)
#5 C:\inetpub\wwwroot\system\ee\EllisLab\ExpressionEngine\Core\Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#6 C:\inetpub\wwwroot\system\ee\EllisLab\ExpressionEngine\Boot\boot.php(151): EllisLab\ExpressionEngine\Core\ in C:\inetpub\wwwroot\system\user\addons\ajw_datagrab\mcp.ajw_datagrab.php on line 208

Profile
 
Posted: 24 June 2019 05:34 PM —   [ # 1 ]  
Newbie
Rank
Total Posts:  2
Joined  2019-05-29

Could really use any idea’s on this! I’m at my wits end with this issue.

EE 5.2.2
DataGrab 3.0.3
Webserver: IIS 10
PHP: 7

Profile
 
Posted: 27 June 2019 08:17 AM —   [ # 2 ]  
Administrator
Avatar
RankRankRankRank
Total Posts:  1354
Joined  2006-04-12

Hi,

Apologies for not replying sooner - a family illness has kept me out of the office for a little while.

Could you email me at support@brandnewbox.co.uk and (if possible) send me a sample of your data.

Thanks,
Andrew

Profile
 
Posted: 15 October 2019 06:58 AM —   [ # 3 ]  
Newbie
Rank
Total Posts:  1
Joined  2019-10-15

I got this initialization error, as well. Though, I was able to solve this error once I started to write my essay. I don’t know how the error got solved by doing this, but it did, and that’s why I am sharing this with you.

Profile
 

‹‹ JSON Import - username and password      status required ››

Select A Theme